
<!DOCTYPE html>
<html lang="en">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
<title>GoLocalProv | 10 Great Things to do in RI This Weekend - December 29, 2017</title>
<meta charset="UTF-8" />
<meta name='robots' content='index,follow,archive' />
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,n,t){function r(t){if(!n[t]){var o=n[t]={exports:{}};e[t][0].call(o.exports,function(n){var o=e[t][1][n];return r(o||n)},o,o.exports)}return n[t].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<t.length;o++)r(t[o]);return r}({1:[function(e,n,t){function r(){}function o(e,n,t){return function(){return i(e,[c.now()].concat(u(arguments)),n?null:this,t),n?void 0:this}}var i=e("handle"),a=e(2),u=e(3),f=e("ee").get("tracer"),c=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,n){s[n]=o(d+n,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),n.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,n){var t={},r=this,o="function"==typeof n;return i(l+"tracer",[c.now(),e,t],r),function(){if(f.emit((o?"":"no-")+"fn-start",[c.now(),r,o],t),o)try{return n.apply(this,arguments)}finally{f.emit("fn-end",[c.now()],t)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,n){m[n]=o(l+n)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,c.now()])}},{}],2:[function(e,n,t){function r(e,n){var t=[],r="",i=0;for(r in e)o.call(e,r)&&(t[i]=n(r,e[r]),i+=1);return t}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],3:[function(e,n,t){function r(e,n,t){n||(n=0),"undefined"==typeof t&&(t=e?e.length:0);for(var r=-1,o=t-n||0,i=Array(o<0?0:o);++r<o;)i[r]=e[n+r];return i}n.exports=r},{}],4:[function(e,n,t){n.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,n,t){function r(){}function o(e){function n(e){return e&&e instanceof r?e:e?f(e,u,i):i()}function t(t,r,o,i){if(!d.aborted||i){e&&e(t,r,o);for(var a=n(o),u=m(t),f=u.length,c=0;c<f;c++)u[c].apply(a,r);var p=s[y[t]];return p&&p.push([b,t,r,a]),a}}function l(e,n){v[e]=m(e).concat(n)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(t)}function g(e,n){c(e,function(e,t){n=n||"feature",y[t]=n,n in s||(s[n]=[])})}var v={},y={},b={on:l,emit:t,get:w,listeners:m,context:n,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",f=e("gos"),c=e(2),s={},p={},d=n.exports=o();d.backlog=s},{}],gos:[function(e,n,t){function r(e,n,t){if(o.call(e,n))return e[n];var r=t();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,n,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[n]=r,r}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],handle:[function(e,n,t){function r(e,n,t,r){o.buffer([e],r),o.emit(e,n,t)}var o=e("ee").get("handle");n.exports=r,r.ee=o},{}],id:[function(e,n,t){function r(e){var n=typeof e;return!e||"object"!==n&&"function"!==n?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");n.exports=r},{}],loader:[function(e,n,t){function r(){if(!x++){var e=h.info=NREUM.info,n=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&n))return s.abort();c(y,function(n,t){e[n]||(e[n]=t)}),f("mark",["onload",a()+h.offset],null,"api");var t=d.createElement("script");t.src="https://"+e.agent,n.parentNode.insertBefore(t,n)}}function o(){"complete"===d.readyState&&i()}function i(){f("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),f=e("handle"),c=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1044.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=n.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),f("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>
<meta name='description' content='The final weekend of 2017 is here, and there are plenty of ways to celebrate it throughout the state. ' />
<meta name='keywords' content='golocalprov, providence, rhode island, news, sports, weather, entertainment, investigation, rhode island news, rhode island sports, rhode island politics, campaign 2014, digital news, business, news, ocean state, Rhode Island,' />
<meta name='robots' content='index,follow,archive' />
<meta name='geo.position' content='{latitude},{longitude}' />
<meta name='geo.placename' content='{placename}' />
<meta name='geo.region' content='{region}' />
<link rel='schema.DC' href='http://purl.org/dc/elements/1.1/' />
<link rel='schema.DCTERMS' href='http://purl.org/dc/terms/' />
<meta name='DC.title' content='10 Great Things to do in RI This Weekend - December 29, 2017 - GoLocalProv' />
<meta name='DC.creator' content='ChrisS' />
<meta name='DC.subject' content='golocalprov, providence, rhode island, news, sports, weather, entertainment, investigation, rhode island news, rhode island sports, rhode island politics, campaign 2014, digital news, business, news, ocean state, Rhode Island,' />
<meta name='DC.description' content='The final weekend of 2017 is here, and there are plenty of ways to celebrate it throughout the state. ' />
<meta name='DC.publisher' content='GoLocalProv' />
<meta name='DC.date.created' scheme='DCTERMS.W3CDTF' content='2017-12-29T02:24:00-05:00' />
<meta name='DC.date.modified' scheme='DCTERMS.W3CDTF' content='2017-12-29T02:48:20-05:00' />
<meta name='DC.date.valid' scheme='DCTERMS.W3CDTF' content='2018-01-04T13:04:30-05:00' />
<meta name='DC.type' scheme='DCTERMS.DCMIType' content='Text' />
<meta name='DC.rights' scheme='DCTERMS.URI' content='' />
<meta name='DC.format' content='text/html' />
<meta name='DC.identifier' scheme='DCTERMS.URI' content='http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017' />
<link rel="publisher" href="https://plus.google.com/101815756619512191805/" />
<meta property="og:title" content="GoLocalProv | Lifestyle | 10 Great Things to do in RI This Weekend - December 29, 2017" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017" />
<meta property="og:site_name" content="GoLocalProv" />
<meta property="og:description" content="The final weekend of 2017 is here, and there are plenty of ways to celebrate it throughout the state.&nbsp;" />
<meta property="og:image" content="http://www.golocalprov.com/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/callery_500_490_490_90.jpg">
<link rel="shortcut icon" href="/favicon.ico">
<link rel="apple-touch-icon" href="/media/site_logos/icon-iphone.png">
<link rel="apple-touch-icon" sizes="72x72" href="/media/site_logos/icon-ipad.png" />
<link rel="apple-touch-icon" sizes="114x114" href="/media/site_logos/icon-iphone4.png" />
<link rel='stylesheet' type='text/css' media='all' href='http://www.golocalprov.com/cache/min/14938d8a9326736ab7ea4c241974266df9a60743.1510709425.css' />
<!--[if IE]>
			<link rel='stylesheet' type='text/css' media='all' href='/media/css/ie.css' />
			<![endif]-->
<!--[if lte IE 6]>
			<link rel='stylesheet' type='text/css' media='all' href='/media/css/ie6.css' />
			<![endif]-->
<!--[if IE 7]>
			<link rel='stylesheet' type='text/css' media='all' href='/media/css/ie7.css' />
			<![endif]-->
<script type='text/javascript' src='http://gl-advert-delivery.com/revive/www/delivery/spcjs.php?id=1'></script>
<script type="text/javascript" src="http://ajax.microsoft.com/ajax/jquery/jquery-1.7.2.min.js"></script>
<script type="text/javascript">
			if (typeof jQuery == 'undefined') {
			    document.write(unescape("%3Cscript src='/media/js/jquery-1.7.2.min.js' type='text/javascript'%3E%3C/script%3E"));
			}
			</script>
<script type="text/javascript" src="/media/js/mobile_redirect/redirection-mobile.js"></script>
<script>
				SA.redirection_mobile ({
					redirection_param : "mobile_redirect",
					mobile_prefix : "m",
					cookie_hours : "2",
					tablet_redirection : "true",
					keep_path : "true"
				});
			</script>
<script type="text/javascript" src="/media/js/swfobject.js"></script>
<link rel="alternate" type="application/rss+xml" title="GoLocalProv - Main Feed" href="/rss" />
<link rel="alternate" type="application/rss+xml" title="GoLocalProv - Lifestyle" href="/rss/lifestyle" />
<style>

					#ghiorsefactor {
						margin-top:10px;
						display:inline-block;
						min-width:195px;
						float:left;
						white-space:nowrap;
					}
					#ghiorsefactor img {float:right;}

					#ghiorsefactor a {color:#fff;}
					#ghiorsefactor span {
						color: #FF0000;
						font-size: 16px;
						font-weight: 700;
					}

					#ghiorsefactor a:hover {text-decoration:none;}

					#header-subscribe {
						margin-top:15px;
						float:right;
						white-space:nowrap;
						font-size:16px;
					}

					#header-subscribe .red {
						text-transform:uppercase;
						font-weight:700;
						color: #FF0000;
						font-size:18px;
					}

					#header-subscribe a {
						color:#fff;
						text-decoration:none;
					}

					#trending {
						position:absolute;
						bottom:26px;
						max-width:360px;
						overflow-x:hidden;
						color:#fff;
						padding:3px 6px;
						border:1px solid #828282;

					}

					#trending p.title {
						text-transform:uppercase;
						display:inline-block;
						float:left;
						line-height:24px;
						margin-top:3px;
						margin-bottom:0;
					}

					#ticker {
						display:inline-block;
						float:right;
						max-width:280px;
						background-color:#000;
						overflow-x:hidden;
					}

					#ticker p {
						line-height:24px;
						height:24px;
						background-color:#000;
						margin-bottom:0;
					}

					#ticker a {
						font-size:12px;
						color:#fff;
					}
					#nav ul li.special>a:link, #nav ul li.special>a:visited					{background-color:#000;}
					#columns div.home-sidebar-pre{
						margin-top: -935px;
					}

					#status-search {
						position:absolute;
						bottom:26px;
						right:0;
						color:#fff;
						padding:3px 6px;
						border:1px solid #828282;
						max-width:140px;
					}

					#search input {
						background-color:#000;
						color:#fff;
						border:none;
						font-size:14px;
						line-height:24px;
						display:inline-block;
						margin-left:5px;
						max-width:115px;
					}

					#search:before {
						position:absolute;
						bottom:10px;
						left:5px;
					    content: "";
					    display: inline-block;
					    float:left;
					    background: url("http://www.golocalprov.com/media/images/search-loupe.png") no-repeat;
					    width: 20px;
					    height: 20px;
					}

					.home-sidebar-pre-single {padding-bottom:25px;}

					#nav ul li.live {background-color:#8bc248;}

					#nav ul li.live a {color:#fff;}

					#nav ul li.live a:hover {color:#000;}

					#header #logo, #header #bannerad {top:2px;}

				</style>
</head>
<body id="" class="lifestyle  ">
<div id="fb-root"></div>
<script>(function(d, s, id) {
			  var js, fjs = d.getElementsByTagName(s)[0];
			  if (d.getElementById(id)) return;
			  js = d.createElement(s); js.id = id;
			  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=1519073768315874&version=v2.0";
			  fjs.parentNode.insertBefore(js, fjs);
			}(document, 'script', 'facebook-jssdk'));</script>
<div id="container">
<div id="header-subscribe">
<p style="display:inline-block; font-size:0.9em;">Welcome! <a href="http://www.golocalprov.com/members">Login</a> | <a class="register-link" href="http://www.golocalprov.com/members/register">Register</a> • </p>
<p style="display:inline-block;"><a href="http://www.golocalprov.com/newsletter"><span class="red">Subscribe Now:</span> Free Daily EBlast</a></p>
</div>
<div class="clear">&nbsp;</div>
<div id="header">
<div id="logo">
<a href="/"><img src="/media/site_logos/logo_lifestyle.jpg" alt="GoLocalProv" /></a>
</div>
<div id="bannerad" class="ad ad728x90">
<script type="text/javascript">
			      <!--// <![CDATA[
			      	
			          OA_show(8);
			        
			        // ]]> -->
			      </script>
</div>
<div id="status-search">
<span id="search">
<form method="post" action="http://www.golocalprov.com/">
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="56" />
<input type="hidden" name="RES" value="20" />
<input type="hidden" name="meta" value="w3y1xZrdYMKicLT8jzPJs5ne3n5IIuX9igvbfbgamBPPgawTj3eZhC0GKQQAgcTMcND7nxLp2iOiYgvCG9sMWQhqdromO2KMm4vGKub3+deWh0BdiYToyrpGPWV34oz59E+QlZvFst6qCGZlwi8XNoZyiruyW7EKOFPc5LxlAsYs+xxCie7J1TFMvxJeoQYpgaPwJJQtBtB1zyQ5+B9GXeyiGQ3XXE7Z7nGRbWNyi/TMXHN32VKUYUvn0F0Vtha0b/LnSzZkBmFQEwKGYHyE+g4/peByk8CsngAq9KBZ0hBg1KAPySv4xOV+MseiusHBJCNC5WncVmRweOz7JzRL2qH53u20DaNht2Oq4JXB2A+GqcSbpB5DGs7Lp60OLa2n" />
<input type="hidden" name="site_id" value="1" />
<input type="hidden" name="csrf_token" value="9f3709d52d0cd091d27f57228901192b13d9f2a4" />
</div>
<input type="text" name="keywords" id="keywords" value="" size="30" maxlength="100" placeholder="SEARCH">
</form>
</span>
</div>
<div style="clear:both;">&nbsp;</div>
<div id="trending">
<p class="title">Trending</p>
<div id="ticker">
<p style="display: block"><a href="/news/public-should-be-able-to-stop-brown-from-demolishing-historic-houses-says-p"><strong>Public Should Be Able to Stop Brown From Demolishing Historic Houses, Says PPS&#8217; Runyon</strong>&mdash;Public Should Be Able to&#8230;</a></p><p style="display: none"><a href="/politics/side-of-the-rhode-whos-hot-and-whos-not-december-29-2017"><strong>Side of the Rhode: Who&#8217;s Hot and Who&#8217;s Not? - December 29, 2017</strong>&mdash;Side of the Rhode: Who's&#8230;</a></p><p style="display: none"><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017"><strong>10 Great Things to do in RI This Weekend - December 29, 2017</strong>&mdash;10 Great Things to do&#8230;</a></p><p style="display: none"><a href="/lifestyle/friday-on-live-comedian-mencia-and-nutritionist-mulligan"><strong>Friday on LIVE: Comedian Mencia and Nutritionist Mulligan</strong>&mdash;Friday on LIVE: Comedian Mencia&#8230;</a></p><p style="display: none"><a href="/sports/new-cartwrights-21-points-15-assists-helps-pc-cruise-past-st.-johns-94-72"><strong>Cartwright&#8217;s 21 Points, 15 Assists Helps PC Cruise Past St. John&#8217;s 94-72</strong>&mdash;Cartwright's 21 Points, 15 Assists&#8230;</a></p><p style="display: none"><a href="/live/live-rep.-ranglin-vassell-on-need-for-community-response-to-joblessness-gun"><strong>LIVE: Rep. Ranglin-Vassell on Need for Community Response to Joblessness &amp; Gun Violence in RI</strong>&mdash;LIVE: Rep. Ranglin-Vassell on Need&#8230;</a></p><p style="display: none"><a href="/live/north-kingstowns-sullivan-meets-snl-writer-jost-through-wish-come-true"><strong>North Kingstown&#8217;s Sullivan Meets SNL Writer Jost Through Wish Come True</strong>&mdash;North Kingstown's Sullivan Meets SNL&#8230;</a></p><p style="display: none"><a href="/live/live-kelly-of-the-silks-performs-all-i-do-talks-new-music"><strong>LIVE: Kelly of The Silks Performs “All I Do” &amp; Talks New Music</strong>&mdash;LIVE: Kelly of The Silks&#8230;</a></p><p style="display: none"><a href="/live/live-national-law-enforcement-officer-fatalities-down-10-in-2017"><strong>LIVE: National Law Enforcement Officer Fatalities Down 10% in 2017</strong>&mdash;LIVE: National Law Enforcement Officer&#8230;</a></p><p style="display: none"><a href="/lifestyle/7th-annual-frozen-clam-dip-obstaplunge-to-benefit-mentor-rhode-island"><strong>7th Annual Frozen Clam Dip &amp; Obstaplunge to Benefit MENTOR Rhode Island</strong>&mdash;7th Annual Frozen Clam Dip&#8230;</a></p>
</div>
</div>
<img src="http://www.golocalprov.com/media/images/social-bar.jpg" style="bottom:26px; right: 154px; position:absolute;" width="562" usemap="#social-links">
<map name="social-links">
<area shape="rect" coords="0,0,187,37" href="http://www.facebook.com/share.php?u=http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017&title=GoLocalProv| 10 Great Things to do in RI This Weekend - December 29, 2017" target="_blank" title="Share on Facebook">
<area shape="rect" coords="187,0,374,37" href="http://twitter.com/intent/tweet?status=GoLocalProv| 10 Great Things to do in RI This Weekend - December 29, 2017+http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017" target="_blank" title="Share on Twitter">
<area shape="rect" coords="374,0,560,37" href="http://www.linkedin.com/shareArticle?mini=true&url=http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017&title=GoLocalProv| 10 Great Things to do in RI This Weekend - December 29, 2017&source=http://www.golocalprov.com/" target="_blank" title="Share on LinkedIn">
</map>
<div id="nav">
<ul class="sf-menu">
<li><a href="/">Home</a></li>
<li><a href="/news">News</a>
<ul>
<li><a href="/public_notices">Public Notices</a></li>
<li><a href="/patriarca-papers">Patriarca Papers</a></li>
</ul>
</li>
<li class="live"><a href="/live">LIVE</a></li>
<li><a href="/sports">Sports</a>

</li>
<li><a href="/politics">Politics</a>

</li>
<li><a href="/business">Business</a></li>
<li class="special"><a href="/weddings">Weddings</a></li>
<li><a href="/weather">Weather</a></li>
<li><a href="/food">Food</a></li>
<li><a href="/health">Health</a></li>
<li class="active">
<a href="/lifestyle">Lifestyle</a>
</li>
<li><a href="/beauty">Beauty & Fashion</a></li>
<li class="last"><a href="/ArtsNowRI">Events in RI</a></li>
</ul>
</div>
</div>
<div class="clear">&nbsp;</div>
<div id="content">

<div id="main">
<div class="post">
<div class="entry">
<h1>10 Great Things to do in RI This Weekend - December 29, 2017</h1>
<p id="sharelinks">
<a href="http://twitter.com/home?status=10 Great Things to do in RI This Weekend - December 29, 2017:+http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017" title="Share on: Twitter"><img src="/themes/cp_global_images/lg_social_bookmarks/favicons/twitter.png" alt="Twitter Favicon" /></a>
<a href="http://www.facebook.com/sharer.php?u=http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017&amp;t=10 Great Things to do in RI This Weekend - December 29, 2017" title="Share on: Facebook"><img src="/themes/cp_global_images/lg_social_bookmarks/favicons/facebook.png" alt="Facebook Favicon" /></a>
<a href="http://digg.com/submit?phase=2&amp;url=http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017&amp;title=10 Great Things to do in RI This Weekend - December 29, 2017" title="Bookmark on: Digg"><img src="/themes/cp_global_images/lg_social_bookmarks/favicons/digg.png" alt="Digg Favicon" /></a>
<a href="http://reddit.com/submit?url=http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017&amp;title=10 Great Things to do in RI This Weekend - December 29, 2017" title="Bookmark on: Reddit"><img src="/themes/cp_global_images/lg_social_bookmarks/favicons/reddit.png" alt="Reddit Favicon" /></a>
<a href="http://www.stumbleupon.com/submit?url=http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017&amp;title=10 Great Things to do in RI This Weekend - December 29, 2017" title="Bookmark on: StumbleUpon"><img src="/themes/cp_global_images/lg_social_bookmarks/favicons/stumbleupon.png" alt="StumbleUpon Favicon" /></a>
<a href="http://del.icio.us/post?url=http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017&amp;title=10 Great Things to do in RI This Weekend - December 29, 2017" title="Bookmark on: del.icio.us"><img src="/themes/cp_global_images/lg_social_bookmarks/favicons/delicious.png" alt="del.icio.us Favicon" /></a>
<g:plusone size="small"></g:plusone>
<a class="email" target="_blank" href="/email/10-great-things-to-do-in-ri-this-weekend-december-29-2017">Email to a friend</a>
<a class="permalink" href="http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017">Permalink</a>
<iframe src="http://www.facebook.com/plugins/like.php?href=http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017&amp;layout=button_count&amp;show_faces=false&amp;width=450&amp;action=like&amp;colorscheme=light&amp;height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:36px;" allowTransparency="true"></iframe>
</p>
<p class="date">Friday, December 29, 2017</p>
<p class="byline"><em>GoLocalProv Lifestyle Team </em></p>
<div class="clear">&nbsp;</div>
<p>
<div id="entry_image" style="width: 360px" class="right">
<p><img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/callery_500_360_360_90.jpg" alt="" width="360" height="360" /></p>
<p class="caption">Allysen Callery</p>
</div>
The final weekend of 2017 is here, and there are plenty of ways to celebrate it throughout the state.&nbsp;</p>
<p>This weekend&rsquo;s events include Disney on Ice at the Dunkin&rsquo; Donuts Center, the Penguin Plunge at Roger Wheeler State Beach, New Year&rsquo;s Eve celebrations and much more.</p>
<p>To help you figure out which event to go to and when, GoLocalProv has put together a complete guide of what to do and when in the slideshow below.</p>
<p>Happy New year!</p>
<p><strong>See the Great Things to do in RI This Weekend in the Slideshow Below</strong></p>
<div class="clear">&nbsp;</div>
<script type='text/javascript'>
				var ad = '<iframe class="slideshow-ad" width="300" height="250" allowtransparency="true" seamless="1"></iframe>';
				var ad_url = '/ad-zone/17/300/250/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017';
				$(document).ready(function(){
					$('#slideshow .slide_info').each(function(i){
						var charLimit = 1000;
						var adInserted = false;
						var numChars = 0;
						if ($('iframe.slideshow-ad', this).length < 1) {
							$('p, ul, h3, h4', this).each(function(s) {
								var elemLength = $(this).text().length;
								numChars += elemLength;
								if (numChars > charLimit && !adInserted) {
									$(this).after(ad);
									adInserted = true;
								}
							});
							if (!adInserted) {
								$(this).append(ad);
								adInserted = true;
							}
						}
						$('iframe.slideshow-ad', this).each(function(a){
							$(this).data('views', 0);
						});
					});
					$('#slideshow .slides').cycle({
						fx:     'turnDown',
						speed:  'fast',
						timeout: 0,
						pager:  '#nav_slideshow ul',
						next:   '.slideshow_next',
						prev:   '.slideshow_prev',
						// callback fn that creates a thumbnail to use as pager anchor
						pagerAnchorBuilder: function(idx, slide) {
							// return selector string for existing anchor
							return '#nav_slideshow li:eq(' + idx + ') a';
						},
						before: function(curEl, nextEl, opts, fwdFlg) {
							$(nextEl).addClass('has-ad-call');
							var slideshowAd = $('iframe.slideshow-ad', nextEl).first();

							var views = parseInt(slideshowAd.data('views'));
							//console.log('Views before: '+views);
							if (views > 0) {
								slideshowAd.attr('src', slideshowAd.attr('src'));
								//console.log('Ad refreshed')
							} else {
								slideshowAd.attr('src', ad_url);
							}
							slideshowAd.data('views', ++views);
							//console.log('Views: '+slideshowAd.data('views'));

						},
						after: function(curEl, nextEl, opts, fwdFlg) {
							var title_slug = location.pathname + '/slide/' + convertToSlug($(nextEl).find('h2:first').text());
							title_slug  = title_slug.replace('#', '').replace(/\/+/g, '/');
							//ga('send', 'pageview');
							_gaq.push(['_trackPageview', title_slug]);
						}
					});
				});
				function convertToSlug(txt) {
					return txt.toLowerCase().replace(/[^\w ]+/g,'').replace(/ +/g,'-');
				}
			</script>
<hr />
<h1>Related Slideshow: 10 Great Things to do in RI This Weekend - December 29, 2017</h1>
<div id="slideshow-wrap">
<p></p>
<div id="slideshow">
<div class="slides clearfix">
<div class="slide">
<img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/callery_500_400_400_90.jpg" width="400" height="400" alt="" />
<div class="slide_info clearfix">
<a class="slideshow_prev" href="#" title="Previous">Prev</a>
<a class="slideshow_next" href="#" title="Next">Next</a>
<h2>December 29 </h2>
<p><b>Something From a Dream - Tom Petty Tribute at Columbus Theatre&nbsp;</b></p>
<p>The Tom Petty tribute show at Columbus Theatre is a must-see for any Tom Petty fan.&nbsp;</p>
<p>The show features music from local musicians such as&nbsp;Allysen &amp; Ava Callery,&nbsp;The Quahogs, Dylan Sevey &amp; The Gentlemen.&nbsp;</p>
<p>Doors open at 7:30 p.m. and the show begins at 8:30 p.m.&nbsp;</p>
<p><a href="http://columbustheatre.com/events/" target="_blank">Click here for more information</a></p>
</div>
</div>
<div class="slide">
<img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/its_the_little_things_400_364.png" width="400" height="364" alt="" />
<div class="slide_info clearfix">
<a class="slideshow_prev" href="#" title="Previous">Prev</a>
<a class="slideshow_next" href="#" title="Next">Next</a>
<h2>December 29 </h2>
<p><strong>It&#39;s The Little Things Exhibit at ArtProv Gallery&nbsp;</strong></p>
<p>Artists were challenged to create works a maximum size of 12 inches by 12 inches (x 12 inches, if 3D), and the results will be on display in &ldquo;It&rsquo;s The Little Things&rdquo; at ArtProv Gallery.</p>
<p>More than thirty artists are participating in the show, which features up to three pieces by each exhibitor in a wide array of media. All of the works will be for sale.</p>
<p>The exhibit opens at noontime on Saturday.&nbsp;</p>
<p><a href="http://www.artprovgallery.com/" target="_blank">Click here for more information&nbsp;</a></p>
</div>
</div>
<div class="slide">
<img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/Love_Never_Dies_400_355.png" width="400" height="355" alt="" />
<div class="slide_info clearfix">
<a class="slideshow_prev" href="#" title="Previous">Prev</a>
<a class="slideshow_next" href="#" title="Next">Next</a>
<h2>December 30</h2>
<p><strong>Love Never Dies at PPAC</strong></p>
<p>Love Never Dies written by Andrew Lloyd&nbsp;Webber is the sequel&nbsp;to The Phantom of the Opera.&nbsp;</p>
<p>The year is 1907. It is 10 years after his disappearance from the Paris Opera House and the Phantom has escaped to a new life in New York where he lives amongst the screaming joy rides and freak shows of Coney Island. In this new, electrically charged world, he has finally found a place for his music to soar, but he has never stopped yearning for his one true love and musical prot&eacute;g&eacute;e, Christine Daa&eacute;.&nbsp;</p>
<h2><a href="http://www.golocalprov.com/live/ppacs-love-never-dies-lead-cortes-on-live-its-just-beautiful" target="_blank"><strong>See&nbsp;Gardar Thor Cortes on LIVE HERE</strong></a></h2>
<p>The show begins at 7 p.m.&nbsp;</p>
<p><a href="https://www.ppacri.org/events/detail/love-never-dies" target="_blank">Click here for more information&nbsp;</a></p>
</div>
</div>
<div class="slide">
<img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/Salute_to_Vienna_400_406.png" width="400" height="406" alt="" />
<div class="slide_info clearfix">
<a class="slideshow_prev" href="#" title="Previous">Prev</a>
<a class="slideshow_next" href="#" title="Next">Next</a>
<h2>December 30 </h2>
<p><strong>Salute to Vienna New Year&#39;s Concert at The Vets&nbsp;</strong></p>
<p>Inspired by Vienna&rsquo;s New Year&rsquo;s Concert,&nbsp;this celebration blends acclaimed European singers and dancers with local symphonies for a rich cultural experience that will leave your toes tapping. Experience Salute to Vienna New Year&rsquo;s Concert: a toast to life itself.&nbsp;</p>
<p>The concert goes from 2 p.m. to 4:30 p.m.</p>
<p><a href="http://www.thevetsri.com/events/detail/salute-to-vienna-new-years-concert-1" target="_blank">Click here for more information&nbsp;</a></p>
</div>
</div>
<div class="slide">
<img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/storytime01_dfce4613-5056-a36a-09720e3115951a84_400_400_90.jpg" width="400" height="400" alt="" />
<div class="slide_info clearfix">
<a class="slideshow_prev" href="#" title="Previous">Prev</a>
<a class="slideshow_next" href="#" title="Next">Next</a>
<h2>December 30 </h2>
<p><strong>Kids Story Time at Books on the Square&nbsp;</strong></p>
<p>Parents and children can join storytellers twice each week for the ongoing Story Time event.&nbsp;</p>
<p>This event is best suited for children 6 months&ndash;6 years old.</p>
<p>The event goes from 11 a.m. to 11:30 p.m.&nbsp;</p>
<p><a href="http://www.booksq.com/events" target="_blank">Click here for more information&nbsp;</a></p>
</div>
</div>
<div class="slide">
<img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Sports/URI_Bball_2017-18/Jared_Terrell_Celebration_400_451.png" width="400" height="451" alt="" />
<div class="slide_info clearfix">
<a class="slideshow_prev" href="#" title="Previous">Prev</a>
<a class="slideshow_next" href="#" title="Next">Next</a>
<h2>December 30 </h2>
<p><strong>URI vs George Mason at Ryan Center&nbsp;</strong></p>
<p>The URI Rams begin their A-10 title defense on Saturday when they host George Mason at the Ryan Center.&nbsp;</p>
<p>The Rams finished their non-conference schedule with a record of 8-3 overall and ride a three-game&nbsp;winning&nbsp;streak into A-10 play.&nbsp;</p>
<p>Game time is set for 4 p.m.&nbsp;</p>
<p><a href="http://www.gorhody.com" target="_blank">Click here for more information&nbsp;</a></p>
</div>
</div>
<div class="slide">
<img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/new_years_party_500_400_398_90.jpg" width="400" height="398" alt="" />
<div class="slide_info clearfix">
<a class="slideshow_prev" href="#" title="Previous">Prev</a>
<a class="slideshow_next" href="#" title="Next">Next</a>
<h2>December 31 </h2>
<p><strong>NYE One Providence at Waterplace Park</strong></p>
<p>Celebrate the New Year in Providence at the New Year&#39;s Eve One Providence celebration at Waterplace Park.&nbsp;</p>
<p>Enjoy food trucks, as Financial Way will be closed, hot chocolate, face painting, music, a laser light show around the basin of Waterplace Park, the countdown with the first-ever ball drop, a fireworks finale and more.</p>
<p>The event begins at 7 p.m.&nbsp;</p>
<p><a href="http://www.nyebyskyline.com/" target="_blank">Click here for more information&nbsp;</a></p>
</div>
</div>
<div class="slide">
<img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/masqueball12_391_358_90.jpg" width="391" height="358" alt="" />
<div class="slide_info clearfix">
<a class="slideshow_prev" href="#" title="Previous">Prev</a>
<a class="slideshow_next" href="#" title="Next">Next</a>
<h2>December 31 </h2>
<p><strong>A Midnight Masquerade in The Ballroom at the ProvidenceG</strong></p>
<p>The masquerade features a red carpet arrival, raw bar buffet, fine food stations, specialty cocktails and a dessert buffet. Dance the night away and sip champagne during a live&nbsp;midnight&nbsp;countdown.</p>
<p>Entertainment will be provided by The New Providence Big Band with Miss Katie Kleyla.</p>
<p>The event begins at 8 p.m.&nbsp;</p>
<p><a href="http://nyeprovidence.com/" target="_blank">Click here for more information&nbsp;</a></p>
</div>
</div>
<div class="slide">
<img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/7th_Obstaplunge_400_400_90.jpg" width="400" height="400" alt="" />
<div class="slide_info clearfix">
<a class="slideshow_prev" href="#" title="Previous">Prev</a>
<a class="slideshow_next" href="#" title="Next">Next</a>
<h2>January 1 </h2>
<p><strong>Frozen Clam Dip &amp; Obstaplunge at Goddard Memorial State Park Beach</strong></p>
<p>The event is the only New Year&rsquo;s Day plunge featuring an obstacle course in the world.</p>
<p>The plunge is for all ages and provides both a traditional plunge into Narragansett Bay and a half-mile American Ninja Warrior type shoreline obstacle course before the plunge.</p>
<p>BoldrDash will provide an additional obstacle from their event series as part of the Obstaplunge.&nbsp;</p>
<p>All proceeds from the event will benefit&nbsp;MENTOR Rhode Island.&nbsp;</p>
<p>The event begins at 12 p.m.</p>
<p><a href="https://www.facebook.com/events/1509239479112009/" target="_blank">Click here for more information&nbsp;</a></p>
 </div>
</div>
<div class="slide">
<img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/Penquin-Plunge_400_315_90.jpg" width="400" height="315" alt="" />
<div class="slide_info clearfix">
<a class="slideshow_prev" href="#" title="Previous">Prev</a>
<a class="slideshow_next" href="#" title="Next">Next</a>
<h2>January 1 </h2>
<p><strong>Penguin Plunge at Roger Wheeler State Beach&nbsp;</strong></p>
<p>Don&#39;t miss the annual Penguin Plunge at Roger Wheeler State Beach to benefit Special Olympics RI.&nbsp;</p>
<p>The plunge takes place at noon.&nbsp;</p>
<p><a href="https://specialolympicsri.org/events/penguin-plunge/" target="_blank">Click here for more information&nbsp;</a></p>
</div>
</div>
</div>
</div>
<div id="nav_slideshow">
<a class="slideshow_prev" href="#" title="Previous">Prev</a>
<ul>
<li><a href="#"><img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/callery_500_80_80_90_c1.jpg" width="80" height="80" alt="" /><br />December 29 </a></li><li><a href="#"><img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/its_the_little_things_80_80_c1.png" width="80" height="80" alt="" /><br />December 29 </a></li><li><a href="#"><img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/Love_Never_Dies_80_80_c1.png" width="80" height="80" alt="" /><br />December 30</a></li><li><a href="#"><img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/Salute_to_Vienna_80_80_c1.png" width="80" height="80" alt="" /><br />December 30 </a></li><li><a href="#"><img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/storytime01_dfce4613-5056-a36a-09720e3115951a84_80_80_90_c1.jpg" width="80" height="80" alt="" /><br />December 30 </a></li><li><a href="#"><img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Sports/URI_Bball_2017-18/Jared_Terrell_Celebration_80_80_c1.png" width="80" height="80" alt="" /><br />December 30 </a></li><li><a href="#"><img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/new_years_party_500_80_80_90_c1.jpg" width="80" height="80" alt="" /><br />December 31 </a></li><li><a href="#"><img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/masqueball12_80_80_90_c1.jpg" width="80" height="80" alt="" /><br />December 31 </a></li><li><a href="#"><img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/7th_Obstaplunge_80_80_90_c1.jpg" width="80" height="80" alt="" /><br />January 1 </a></li><li><a href="#"><img src="/cache/images/cached/cache/images/remote/http_s3.amazonaws.com/media.golocalprov.com/Lifestyle/Penquin-Plunge_80_80_90_c1.jpg" width="80" height="80" alt="" /><br />January 1 </a></li>
</ul>
<a class="slideshow_next" href="#" title="Next">Next</a>
<div class="clear">&nbsp;</div>
</div>
<div class="clear">&nbsp;</div>
</div>
<div class="clear">&nbsp;</div>
<h3>Related Articles</h3>
<ul>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-august-25-2017">10 Great Things to do in RI This Weekend - August 25, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-august-18-2017">10 Great Things to do in RI This Weekend - August 18, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-september-1-2017">10 Great Things to do in RI This Weekend - September 1, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-september-8-2017">10 Great Things to do in RI This Weekend - September 8, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-september-15-2017">10 Great Things to do in RI This Weekend - September 15, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-august-11-2017">10 Great Things to do in RI This Weekend - August 11, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-august-4-2017">10 Great Things to do in RI This Weekend - August 4, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-july-7-2017">10 Great Things to do in RI This Weekend - July 7, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-july-14-2017">10 Great Things to do in RI This Weekend - July 14, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-july-21-2017">10 Great Things to do in RI This Weekend - July 21, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-july-28-2017">10 Great Things to do in RI This Weekend - July 28, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-september-22-2017">10 Great Things to do in RI This Weekend - September 22, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-september-29-2017">10 Great Things to do in RI This Weekend - September 29, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-november-24-2017">10 Great Things to do in RI This Weekend - November 24, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-november-17-2017">10 Great Things to do in RI This Weekend - November 17, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-1-2017">10 Great Things to do in RI This Weekend - December 1, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-8-2017">10 Great Things to do in RI This Weekend - December 8, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-15-2017">10 Great Things to do in RI This Weekend - December 15, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-november-10-2017">10 Great Things to do in RI This Weekend - November 10, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-november-3-2017">10 Great Things to do in RI This Weekend - November 3, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-october-6-2017">10 Great Things to do in RI This Weekend - October 6, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-october-13-2017">10 Great Things to do in RI This Weekend - October 13, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-october-20-2017">10 Great Things to do in RI This Weekend - October 20, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-october-27-2017">10 Great Things to do in RI This Weekend - October 27, 2017</a></li>
<li><a href="/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-22-2017">10 Great Things to do in RI This Weekend - December 22, 2017</a></li>
</ul>
<div class="clear">&nbsp;</div>
<br />
<h4>Enjoy this post? Share it with others.</h4>
<p id="sharelinks">
<a href="http://twitter.com/home?status=10 Great Things to do in RI This Weekend - December 29, 2017:+http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017" title="Share on: Twitter"><img src="/themes/cp_global_images/lg_social_bookmarks/favicons/twitter.png" alt="Twitter Favicon" /></a>
<a href="http://www.facebook.com/sharer.php?u=http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017&amp;t=10 Great Things to do in RI This Weekend - December 29, 2017" title="Share on: Facebook"><img src="/themes/cp_global_images/lg_social_bookmarks/favicons/facebook.png" alt="Facebook Favicon" /></a>
<a href="http://digg.com/submit?phase=2&amp;url=http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017&amp;title=10 Great Things to do in RI This Weekend - December 29, 2017" title="Bookmark on: Digg"><img src="/themes/cp_global_images/lg_social_bookmarks/favicons/digg.png" alt="Digg Favicon" /></a>
<a href="http://reddit.com/submit?url=http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017&amp;title=10 Great Things to do in RI This Weekend - December 29, 2017" title="Bookmark on: Reddit"><img src="/themes/cp_global_images/lg_social_bookmarks/favicons/reddit.png" alt="Reddit Favicon" /></a>
<a href="http://www.stumbleupon.com/submit?url=http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017&amp;title=10 Great Things to do in RI This Weekend - December 29, 2017" title="Bookmark on: StumbleUpon"><img src="/themes/cp_global_images/lg_social_bookmarks/favicons/stumbleupon.png" alt="StumbleUpon Favicon" /></a>
<a href="http://del.icio.us/post?url=http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017&amp;title=10 Great Things to do in RI This Weekend - December 29, 2017" title="Bookmark on: del.icio.us"><img src="/themes/cp_global_images/lg_social_bookmarks/favicons/delicious.png" alt="del.icio.us Favicon" /></a>
<g:plusone size="small"></g:plusone>
<a class="email" href="/email/10-great-things-to-do-in-ri-this-weekend-december-29-2017">Email to a friend</a>
<a class="permalink" href="http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017">Permalink</a>
<iframe src="http://www.facebook.com/plugins/like.php?href=http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017&amp;layout=button_count&amp;show_faces=false&amp;width=450&amp;action=like&amp;colorscheme=light&amp;height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:36px;" allowTransparency="true"></iframe>
</p>
</div>
<div class="clear">&nbsp;</div>
</div>
<div class="comments">
<div class="fb-comments" data-href="http://www.golocalprov.com/lifestyle/10-great-things-to-do-in-ri-this-weekend-december-29-2017" data-numposts="5" data-colorscheme="light"></div>
</div>
</div>
<div id="sidebar">
<div class="ad ad300x90 top">
<script type="text/javascript">
							<!--// <![CDATA[
								
									OA_show(9);
								
								// ]]> -->
							</script>
</div>
<div class="clear">&nbsp;</div>
<div class="ad ad160x600">
<script type="text/javascript">
							<!--// <![CDATA[
									OA_show(14);
								// ]]> -->
							</script>
</div>
<div class="ad ad120x600">
<script type="text/javascript">
							<!--// <![CDATA[
									OA_show(13);
								// ]]> -->
							</script>
</div>
<div class="clear">&nbsp;</div>
<div class="ad ad300x250">
<script type="text/javascript">
							<!--// <![CDATA[
									OA_show(10);
								// ]]> -->
							</script>
</div>
<div class="ad ad300x250">
<script type="text/javascript">
							<!--// <![CDATA[
									OA_show(11);
								// ]]> -->
							</script>
</div>
<div class="ad ad300x250">
<script type="text/javascript">
							<!--// <![CDATA[
									OA_show(12);
								// ]]> -->
							</script>
</div>
<div class="ad ad160x600">
<script type="text/javascript">
							<!--// <![CDATA[
									OA_show(14);
								// ]]> -->
							</script>
</div>
<div class="ad ad120x600">
<script type="text/javascript">
							<!--// <![CDATA[
									OA_show(13);
								// ]]> -->
							</script>
</div>
<div class="clear">&nbsp;</div>
<div class="fb-activity" data-site="www.golocalprov.com" data-action="likes, recommends" data-colorscheme="light" data-header="true"></div>
<div class="clear">&nbsp;</div>
<div class="clear">&nbsp;</div>
</div>
<div id="endpage-box" class="endpage-box">
<img src="/media/site_logos/endbox-logo.jpg">
<div class="endpage-content">
<h3>Sign Up for the Daily Eblast</h3>

<form action="/newsletter" method="post" novalidate>
<input type="email" value="" name="email" class="required email" id="email" placeholder="Email address"> <input type="submit" value="GO!" name="subscribe" id="mc-embedded-subscribe" class="button">
</form>
<p><a href="https://twitter.com/golocalprov/" target="_blank">I want to follow on Twitter <img src="/media/images/endbox-tw.png" style="padding-left:15px;"></a></p>
<p><a href="https://www.facebook.com/golocalprov/" target="_blank">I want to Like on Facebook <img src="/media/images/endbox-fb.png" style="padding-left:5px;"></a></p>
</div>
</div>
<script src="/media/js/jquery.endpage-box.min.js"></script>
<script>
$(function() {
$("#endpage-box").endpage_box({
  animation: "flyInRight",
  from: "8%",
  to: "110%"
});
});
</script>
<script src="/media/js/CoverPop.min.js"></script>
<div id="CoverPop-cover" class="splash">
<div class="CoverPop-content">
<div class="splash-center-top splash-center-top-alt">
<img src="/media/images/paperboy.jpg" style="float:right; margin-right:-22px; margin-top: -8px;">
Delivered <u>Free</u> Every<br>
Day to Your Inbox
</div>
<div class="splash-center">
<h3>Sign Up for the Daily Eblast</h3>

<form action="/newsletter" method="post" novalidate>
<input type="email" value="" name="email" class="required email" id="email" placeholder="Email address"> <input type="submit" value="GO!" name="subscribe" id="mc-embedded-subscribe" class="button CoverPop-close-go">
</form>
<p><a href="https://twitter.com/golocalprov/" target="_blank">I want to follow on Twitter <img src="/media/images/endbox-tw.png" style="padding-left:18px;"></a></p>
<p><a href="https://www.facebook.com/GoLocalProv/" target="_blank">I want to Like on Facebook <img src="/media/images/endbox-fb.png" style="padding-left:5px;"></a></p>
<p class="mobile-x-alt"><a href="#" class="CoverPop-close">X</a></p>
</div>
</div>
</div>
<div class="clear">&nbsp;</div>
<div id="footer">
<ul>
<li><a href="/">Home</a></li>
<li><a href="/news">News</a></li>
<li><a href="/politics">Politics</a></li>
<li><a href="/sports">Sports</a></li>
<li><a href="/business">Business</a></li>
<li><a href="http://realestate.golocalprov.com/">Real Estate</a></li>
<li><a href="/weather">Weather</a></li>
<li><a href="/health">Health</a></li>
<li><a href="/lifestyle">Lifestyle</a></li>
</ul>
<ul>
<li><a href="/about">About Us</a></li>
<li><a href="/terms">Terms and Conditions</a></li>
<li><a href="/privacy">Privacy Policy</a></li>
<li><a href="/advertise-with-us">Advertise With Us</a></li>
<li><a href="/contact">Contact Us</a></li>
</ul>
<ul>
<li>Copyright 2017 - GoLocalProv</li>
</ul>
</div>
<div style="text-align: center">
<a href="https://monitor18.sucuri.net/verify.php?r=c5f6e21a650df73f1c865e16ce678eba7469568dc6"><img src="http://sucuri.net/images/badge2.png" /></a>
</div>
</div>
</div>
<script>
				  // (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
				  // (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
				  // m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
				  // })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

				  // ga('create', 'UA-16073942-1', 'auto');
				  // ga('send', 'pageview');

					var _gaq = _gaq || [];
					_gaq.push(['_setAccount', 'UA-16073942-1']);
					_gaq.push(['_setDomainName', 'golocalprov.com']);
					_gaq.push(['_trackPageview']);
					(function() {
						var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
						ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
						var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
					})();



				</script>
<script type="text/javascript" src="http://www.golocalprov.com/cache/min/99e8eb42125bf9a146e00b81a491f5a51c11d4f6.1409949443.js"></script>
<script type="text/javascript">
				    if ( $( "#masonry" ).length ) {
					    var container = document.querySelector('#masonry');
					    var stampElem = document.querySelector('.stamp');
					    var msnry = new Masonry( container, {
					      // options
					      itemSelector: '.entry',
								columnWidth: 345,
								gutter: 20
					    });
						}
				</script>
<script type="text/javascript">
				$(document).ready(function() {
					$('#ticker').cycle({ fx: 'scrollUp', timeout: 4000, speed: 1000, pause: 1 });
					$('#radioticker').cycle({ fx: 'scrollLeft', timeout: 5000, speed: 1000, pause: 1});
					$('#vw_slides').after('<div id="vw_pager">').cycle({
						fx: 'fade',
						timeout: 4000,
						speed: 1000,
						pause: 1,
						pager: '#vw_pager',
						before: function(curEl, nextEl, opts, fwdFlg) {
							try {
								var slideURL = document.createElement('a');
								slideURL.href = $(curEl).find('a:first').attr('href');
								var trckURL = (slideURL.pathname.startsWith('/')) ? '/home'+slideURL.pathname : '/home/'+slideURL.pathname;
								// ga('send', 'pageview');
								_gaq.push(['_trackPageview', trckURL]);
							} catch(err) {}}
					});
					$("#nav .sf-menu").superfish();
				});
				if (typeof String.prototype.startsWith != 'function') {
					String.prototype.startsWith = function (str){
						return this.indexOf(str) == 0;
					};
				}
				</script>
<script>
					var _comscore = _comscore || [];
					_comscore.push({ c1: "2", c2: "14326735" });
					(function() {
						var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
						s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
						el.parentNode.insertBefore(s, el);
					})();
				</script>
<noscript>
				<img src="http://b.scorecardresearch.com/p?c1=2&c2=14326735&cv=2.0&cj=1" />
				</noscript>
:!
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"8ca922ff36","applicationID":"19345637","transactionName":"YldQNhAAC0NVV0BdDVsdcRcRFQpdG1hdUgdGRksOB05UABlTRlEDQR9GCgsPAkMZQFsZBlofWwxPEwwdQFxdR09CV1cJBw8BHVBRV1EPV1dAT1BYSAIEBQM=","queueTime":0,"applicationTime":388,"atts":"ThBTQFgaGE0=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>